Can't load modules anymore that worked last week without problem

Primary informations

Username: $ramisch
Cluster: $baobab


I want to run ipython on an interactive note importing, among others, the snapatac2 package. Until last week, this was working fine. Today I got an error loading the corresponding modules (before even opening ipython).

Steps to Reproduce

This is what I did usually:
First, opening interactive node (today it’s cpu322), then loading the modules, and afterwards opening ipython (not shown, since I don’t reach that step).

ml GCC/12.3.0 OpenMPI CMake python-igraph

Lmod has detected the following error: These module(s) or extension(s) exist but cannot be loaded as requested:
“ScaLAPACK/2.0.2”, “expat/2.2.7”, “freetype/2.10.1”, “OpenMPI/3.1.4”, “Boost/1.71.0”, “pkg-config/0.29.2”, “LibTIFF/4.0.10”,
“libjpeg-turbo/2.0.3”, “GLib/2.62.0”, “libtool/2.4.6”, “GSL/2.6”, “Autoconf/2.69”, “SciPy-bundle/2019.10-Python-3.7.4”,
“Mesa/19.1.7”, “UDUNITS/2.2.26”, “cairo/1.16.0”, “GATK/”, “libunwind/1.3.1”, “nettle/3.5.1”,
“fontconfig/2.13.1”, “util-linux/2.34”, “libpng/1.6.37”, “HDF5/1.10.5”, “pkgconfig/1.5.1-Python-3.7.4”, “CMake/3.15.3”,
“JasPer/2.0.14”, “Autotools/20180311”, “libGLU/9.0.1”, “Automake/1.16.1”, “Ghostscript/9.50”, “X11/20190717”, “XZ/5.2.4”,
“Biopython/1.75-Python-3.7.4”, “Tk/8.6.9”, “NLopt/2.6.1”, “SAMtools/1.10”, “pixman/0.38.0”, “Python/3.7.4”, “OpenBLAS/0.3.7”,
“FFTW/3.3.8”, “PCRE/8.43”, “Perl/5.30.0”, “libsndfile/1.0.28”, “LLVM/9.0.0”, “ImageMagick/7.0.9-5”, “LittleCMS/2.9”,
“ICU/64.2”, “git/2.23.0-nodocs”, “R/3.6.2”, “libdrm/2.4.99”, “NASM/2.14.02”
Try: “module spider ScaLAPACK/2.0.2 expat/2.2.7 freetype/2.10.1 OpenMPI/3.1.4 Boost/1.71.0 pkg-config/0.29.2 LibTIFF/4.0.10
libjpeg-turbo/2.0.3 GLib/2.62.0 libtool/2.4.6 GSL/2.6 Autoconf/2.69 SciPy-bundle/2019.10-Python-3.7.4 Mesa/19.1.7
UDUNITS/2.2.26 cairo/1.16.0 GATK/ libunwind/1.3.1 nettle/3.5.1 fontconfig/2.13.1 util-linux/2.34 libpng/1.6.37
HDF5/1.10.5 pkgconfig/1.5.1-Python-3.7.4 CMake/3.15.3 JasPer/2.0.14 Autotools/20180311 libGLU/9.0.1 Automake/1.16.1
Ghostscript/9.50 X11/20190717 XZ/5.2.4 Biopython/1.75-Python-3.7.4 Tk/8.6.9 NLopt/2.6.1 SAMtools/1.10 pixman/0.38.0
Python/3.7.4 OpenBLAS/0.3.7 FFTW/3.3.8 PCRE/8.43 Perl/5.30.0 libsndfile/1.0.28 LLVM/9.0.0 ImageMagick/7.0.9-5 LittleCMS/2.9
ICU/64.2 git/2.23.0-nodocs R/3.6.2 libdrm/2.4.99 NASM/2.14.02” to see how to load the module(s).

Even if I check

module spider python-igraph/0.11.2

this should work, but it doesn’t:

ml GCC/12.3.0 OpenMPI/4.1.5 python-igraph/0.11.2

Lmod has detected the following error: The following module(s) are unknown: “OpenBLAS/0.3.23”

Since it took me a while, also with help of HPC, to even get the snapatac2 working, I wanted to understand what has happened with these modules before trying anything else.

Thanks already for your help,

Dear @Anna.Ramisch

We detect something wrong with OpenBlas, the module is re-compiling.

However , you tried to load GCC/12.3.0 with ScaLAPACK/2.0.2 but this version of scalapack is compatible with GCC/8.3.0:

(baobab)-[alberta@login2 ~]$ ml spider  ScaLAPACK/2.0.2

  ScaLAPACK: ScaLAPACK/2.0.2
      The ScaLAPACK (or Scalable LAPACK) library includes a subset of LAPACK routines redesigned for distributed memory MIMD parallel computers.

    You will need to load all module(s) on any one of the lines below before the "ScaLAPACK/2.0.2" module is available to load.

      GCC/8.3.0  CUDA/10.1.243  OpenMPI/3.1.4
      GCC/8.3.0  OpenMPI/3.1.4

Once OpenBlas has been recompiled, it should work perfectly.

We apologize for any inconvenience caused.

Dear @Anna.Ramisch OpenBLAS is available again. Sorry for the issue. The reason of the “downtime” is [baobab][python package][virtualenv] Error raised on "shap" package load - Illegal instruction (core dumped) - #5 by Yann.Sagon . Usually we compile the software on a staging area and you even don’t notice the replacement but this time we faced a bug and the stagging area was synchronized with the production area too early.

Thank you very much Yann and Adrien,
it’s all working again :slight_smile: