Command module Not found

Following on from the issue mentioned here module not found.

I tried editting my submit file to look like this:

#!/bin/sh -l

#SBATCH --job-name=CoCo
#SBATCH --cpus-per-task=1
#SBATCH --time=0-12:00:00
#SBATCH --partition=private-dpnc-gpu,shared-gpu
#SBATCH --output=/home/users/s/senguptd/UniGe/combinatorial/combinatorics/jobs/slurm-%A-%x_%a.out
#SBATCH --chdir=/home/users/s/senguptd/UniGe/combinatorial/combinatorics
#SBATCH --mem=10GB
#SBATCH --gpus=1

module load GCCcore/8.2.0 Singularity/3.4.0-Go-1.12
export PYTHONPATH=${PWD}:${PWD}/python_install:${PYTHONPATH}

srun singularity exec --nv -B /home/users/s/senguptd/UniGe/combinatorial/combinatorics/,/srv/beegfs/scratch/groups/rodem/ttbar_evt_reco/topographs/:/top_data/,/srv/beegfs/scratch/users/s/senguptd/:/scratch/ /home/users/s/senguptd/UniGe/combinatorial/combinatorics/container/coco.sif python scripts/

Submitting this gives me an error:

e[31mFATAL:  e[0m container creation failed: mount /proc/self/fd/10->/opt/ebsofts/Singularity/3.4.0-GCCcore-8.2.0-Go-1.12/var/singularity/mnt/session/rootfs error: can't mount image /proc/self/fd/10: kernel reported a bad superblock for squashfs image partition, possible causes are that your kernel doesn't support the compression algorithm or the image is corrupted
srun: error: gpu002: task 0: Exited with exit code 255

I am currently mounted on a cpu node via VSCode, and using the singularity there has no complaints about this image.

I am not sure what’s going wrong here. Any help is appreciated.


The solution was simple in the end. Looks like there was a version conflict, loading up the latest singularity solved the issue.

module load GCC/9.3.0 Singularity/3.7.3-Go-1.14

1 Like