Conflicting EasyBuild dependencies R/4.0.0 and GEOS/3.8.0

Dear colleagues,

I’m trying to use the SPMLE package in R built by Philipp Huntziker (GitHub - hunzikp/spmle: Binary Choice Models Using PMLE). The package itself needs to be downloaded from github using devtools in R.

The spmle package requires the rgeos package, which itself requires GEOS to be running. There is unfortunately an easybuild dependency conflict between the softwares:
GEOS/3.8.0-Python/3.7.4 requires GCC/8.3.0
R/4.0.0 requires GCC/9.3.0 and OpenMPI/4.0.3

I tried using R/3.6.2 considering it uses GCC/8.3.0. Still, I received an error when I tried to install the spmle package.

.Rout error description

More generally I’m quite reluctant to use the R/3.6.2 version, as I’m already downgrading from R/4.0.2 on my own computer. The SPMLE package was also built in June 2020.

Is the solution the compile one of the sofwatre (like in the [howto])? If so, which one? As I’m very new to HPC, unfortunately I cannot understand in which way to use the [howto compile a software] to solve my problem.

Thanks for your help. All the best,


Hi Cecile,

we’ve installed a new GEOS and rgeos version New software installed GEOS and rgeos that are compatible with R version 4.0.0.

In your case, the error you have in the screenshot is probably because you have an incompatible Rccp version as you probably installed it with R 4.0.0 and it isn’t working with R 3.6.2. Just erase it.



Hi Yann,

Thank you very much for your help ! Best,