Error when loading .root files from EOS

Hello,

I’m working with the ROOT package and using input files located in the EOS filesystem.

I’ve been working flawlessly with the same files for the last month, while recently I’m experiencing some problems.
In particular, when trying to open some of them I get the following error:

SysError in <TFile::TFile>: file  my_file.root can not be opened for reading (Invalid argument)

If I open the same file from LXPLUS (CERN machines) everything looks fine, the files doesn’t seem to be corrupted.

This error seems to appear with an irregular pattern. Some days everything goes smoothly, while sometime, files just won’t open. Moreover, it happens that file X is giving errors when working on yggdrasil node, but not baobab, while for file Y might be the opposite.

I’ve tried different versions of the ROOT package and still get the same problem.

I might be doing something wrong in the procedure to mount EOS.
I’m currently going trough these steps:

# obtain a valid kerberos ticket
kinit username@CERN.ch  
# declare Paths
export EOS_MGM_URL="root://eosatlas.cern.ch"
export EOS_HOME="/eos/atlas"
# mount via fuse
eos fuse mount ${HOME}/eosatlas

Otherwise, I’m not sure which could be the source of the problem.

Any help with this would much appreciated!

Thanks for your patience.

Stefano