FreeSurfer FreeView on login node

Dear Baobab experts,

Given the current order to work from home from UNIGE, I have tried to run FreeSurfer’s FreeView GUI on Baobab’s login node (rather than on a dedicated machine at unige that I can’t access remotely). I first enable FreeSurfer as recommended on the uni’s gitlab:

module load FreeSurfer/6.0.0-centos6_x86_64
source $FREESURFER_HOME/SetUpFreeSurfer.sh
export SUBJECTS_DIR=~/GVA_iEEG_freesurfer_subjects

Then, when I try to run freeview, I get the following error:

freeview.bin: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory

I realize that this is not strictly related to the HPC, but given that I’m kind of stuck… I was wondering whether anyone attempted that and solved the same issue.

Thanks in advance,

Pierre

Hi Pierre,

encountered a similar problem, when I tired to install Freesurfer on my local Linux machine. The problem was that the library that was dealing with png file formats were not up to date. I was using Ubuntu 18.04, which I believe had an older version than what Freesurfer 6 required and I had to install it manually.

Boabab is on Centos 6, and I am not sure which version of libpng it has (quick googling showed 1.2, but I am not exactly sure). Maybe it is not even installed, then you can try install it yourself with

yum install libpng-devel

It might be you will need to have sudo privileges and I am not sure, if you can install packages yourself in Baobab.

Sorry, not much of help :slight_smile: but you may give it a try until someone more knowledgeable responses.

Hi there,

Baobab was migrated to CentOS 7 more than six months ago (cf. Baobab migration from CentOS6 to CentOS7 - #3 by Massimo.Brero ) and the internal documentation clearly states that (cf. https://baobab.unige.ch/enduser/src/enduser/access.html#connection ).

Please do NOT install system packages, everything you need for your analysis should come either from module (cf. https://baobab.unige.ch/enduser/src/enduser/applications.html#end-user-applications ) or by manual compilation, except for upstream binaries for which you do not have the sources.

Moreover, no end user has sudo privileges on Baobab.

BTW, here how to find the version of an installed system library:

capello@login2:~$ rpm -qa | \
 grep libpng
libpng-1.5.13-7.el7_2.x86_64
libpng-devel-1.5.13-7.el7_2.x86_64
capello@login2:~$ rpm -ql libpng-1.5.13-7.el7_2.x86_64 | \
 grep -e '/lib.*\.so'
/usr/lib64/libpng15.so.15
/usr/lib64/libpng15.so.15.13.0
capello@login2:~$ 

Please note that as you could see, the ${PACKAGE} version is different from the ${LIBRARY_NAME}, because the latter used the SONAME (cf. soname - Wikipedia ).

Thx, bye,
Luca

Hi there,

That version is too old and thus has problems on Baobab, please use the new one @Yann.Sagon recently compiled (cf. Problem with running FreeSurfer - #2 by Yann.Sagon ) and which has the correct dependency on module:libpng/1.2.58 :

capello@login2:~$ module purge
capello@login2:~$ module load FreeSurfer/6.0.1-centos6_x86_64  
capello@login2:~$ module list

Currently Loaded Modules:
  1) zlib/1.2.11   2) libpng/1.2.58   3) FreeSurfer/6.0.1-centos6_x86_64

 

capello@login2:~$ 

I have corrected the GitLab repository (cf. f/FreeSurfer/sbatch.sh: new version working on CentOS 7 (c0e57c3a) · Commits · hpc / softs · GitLab ).

Thx, bye,
Luca

One more things:
I think it’s not needed anymore to do:

export FREESURFER_HOME=$EBROOTFREESURFER
source $FREESURFER_HOME/SetUpFreeSurfer.sh
export SUBJECTS_DIR=/subjects_paths

as indicated here. If a user can confirm that, we’ll update the sbatch example.

Dear Luca and Yann,

Thank you for your very fast answers. Luca, you were right that changing the version of FreeSurfer fixed my issue with FreeView, which I can now run using X2go.

However, when trying to run the recon-all FreeSurfer pipeline on the cluster “as usual”, with version 6.0.1, I encountered the following error message:

GNU libc version: 2.17
ERROR: Systems running GNU glibc version greater than 2.15
  require a newly formatted license file (it's free). Please
  download a new one from the following page:
  http://surfer.nmr.mgh.harvard.edu/registration.html

That is not a blocking issue for me, as I intend to reconstruct all MRIs in my study with the same version of freesurfer anyway, but I just wanted to let you know.

Thank you again,

Best,

Pierre

Dear Pierre,

I’ve re installed FreeSurfer with a recent license. Thanks for the notification.

Best

Yann