GLIBC versions 2.14 not found

Hello Moupiya,

Indeed in CentOS 6.x , the GLIBC version is still 2.12 and cant’be updated easily.
Why do you need another version of GLIBC? If you are doing mpi stuff, please load for example the following package which contains the GCC compiler and openmpi:

module load foss/2018b

See compilers on Baobab.

Yes you should replace the mpiexec with srun (and don’t specify the number of worker, it’s picked automatically with the number of tasks.

I don’t know what spack is.

If you really need a version of GLIBC more recent, you should connect to the new login node (WIP: Migrate Baobab to CentOS7)

Best