GTK+ incompatibility


I was trying to install a Python package that requires GTK+ development files (>= 3.0.0) and got the following error:

    checking for GTK+ - version >= 3.0.0... no
    *** Could not run GTK+ test program, checking why...
    *** The test program failed to compile or link. See the file config.log for the
    *** exact error that occured. This usually means GTK+ is incorrectly installed.
    configure: error:
    The development files for GTK+ were not found. For GTK+ 2, please
    ensure that pkg-config is in the path and that gtk+-2.0.pc is
    installed. For GTK+ 1.2 please check that gtk-config is in the path,
    and that the version is 1.2.3 or above. Also check that the
    libraries returned by 'pkg-config gtk+-2.0 --libs' or 'gtk-config
    --libs' are in the LD_LIBRARY_PATH or equivalent.

    Error running configure
    ERROR: failed building wxWidgets
    Traceback (most recent call last):
      File "", line 1468, in cmd_build_wx
        wxbuild.main(wxDir(), build_options)
      File "/scratch/pip-install-eg595qkj/wxpython_1358b08c698c4300a7e89242bf429d76/buildtools/", line 371, in main
        exitIfError(wxBuilder.configure(dir=wxRootDir, options=configure_opts),
      File "/scratch/pip-install-eg595qkj/wxpython_1358b08c698c4300a7e89242bf429d76/buildtools/", line 85, in exitIfError
        raise builder.BuildError(msg)
    buildtools.builder.BuildError: Error running configure

The GTK+ 3 modules available on Baobab require GCCcore/8.3.0, which unfortunately is incompatible with the other modules I need to load:

GCCcore/10.2.0 Tkinter/3.8.6 Python/3.8.6 cuDNN/

Would it be possible to make a GTK+ 3 module compiled with GCCcore/10.2.0?

Thank you very much!


Any news?

Thank you very much!

Hi, sorry this message get lost I don’t know why!

Done: New software installed GTK+ 3.24.23 for GCCcore-10.2.0