Issue with R/4.2.1

Hello,
I update this post instead of creating a new one since I also have more or less the same trouble with R/4.2.1 since the last 24h

For months I could run R scripts loading R with this command line:

module load foss/2022a R/4.2.1

since yesterday R doesn’t load and I get this error message:

Lmod has detected the following error: The following module(s) are unknown:

“GDAL/3.5.0”

Please check the spelling or version number. Also try “module spider …”

It is also possible your cache file is out-of-date; it may help to try:

$ module --ignore_cache load “GDAL/3.5.0”

Also make sure that all modulefiles written in TCL start with the string

#%Module

and adding module --ignore_cache load "GDAL/3.5.0 after foss and before R give the following error:

Lmod has detected the following error: The following module(s) are unknown:

“GDAL/3.5.0”

Please check the spelling or version number. Also try “module spider …”

It is also possible your cache file is out-of-date; it may help to try:

$ module --ignore_cache load “GDAL/3.5.0”

Also make sure that all modulefiles written in TCL start with the string

#%Module

the newest version, GDAL/3.3.2, gives exactly the same message, even when loading GCC and OpenMPI individually instead of foss. What can I do ?

Hi @Kevin.Dobretz, same problem here: since a couple of days R/4.2.1 is not loading with the error The following module(s) are unknown: “GDAL/3.5.0”

1 Like

Hi @Kevin.Dobretz and @Samuel.Orso

I’ll check the issue and let you know.