Jupyter-notebook link not working

Primary informations

Username: $khansh
Cluster: $ Yggdrasil


I am trying to run jupyter notebook by following the instructions here ([tutorial] Jupyter notebook)

Steps to Reproduce

copied the files from here (j/jupyter · master · hpc / softs · GitLab). Then used “sbatch launchJupyter.sh” checked the job is running. Then used “grep “running at” -A1 slurm-26873460.out” and a link (http://cpu001:1234/?token=5965f95bf7c18963c38d3081a5e34d5baa8f1a40b1d58b4b) was produced.

Expected Result

to open a webbased interface for jupyter notebook

Actual Result

link does not work on my linux firefox or on my chrome.

Please check this link, it has more details Sign in · GitLab

Thanks it helped but now when I do this on my personal computer
sudo vim .ssh/config
and edit as

Host ygg
  HostName login1.yggdrasil.hpc.unige.ch
  User khansh

Host cpu001
  HostName cpu001
  User khansh
  ProxyJump ygg
  LocalForward 1234 localhost:1234

then ssh ygg
and then in a new terminal do ssh cpu001 it asks for a password for the cpu001.

You shouldn’t connect to ygg but directly to cpu001. This will use the ProxyJump feature.

even tried that but still the same option comes up that give password for cpu001.
This time I had ssh cpu001 only.

Did you tried to type your password?

Yes it asks for password and my normal password works on that one. then it asks for khansh@cpu001’s password


I can confirm that this isn’t working. The reason is that the authentication from login node to compute node isn’t done using normal authentication but using HostbasedAuthentication.

A working solution is

root@CL-hqhk4m2:~# ssh -t sagon@login2.baobab.hpc.unige.ch ssh cpu001
Last login: Mon Sep 11 16:00:15 2023 from
Installed: Thu Aug 17 14:28:26 CEST 2023
(baobab)-[sagon@cpu001 ~]$

Be sure to have a working session on the compute node first.