X2go login troubleshoot

I am trying to login to X2Go. The error message appears to be due to the incorrect password. But I use the same password and login information with Putty and connect fine. Any ideas on a solution?


on which cluster do you connect?

do you have specific stuff in your .bashrc, .bash_profile etc?

did you already managed to connect to the cluster using x2go once?

I was only following the instruction on the site, using these settings:

I have never connected to the cluster with x2go. There was no information about a.bashrc profile. I am on windows, not linux. I think it is the Baobab2 head node.

This was never resolved. It appears to be a problem on my personal PC; however the reason is unknown. What about X11 forwarding with Putty?


by email we wrote you last week the following:

As X2go is using putty under the hood please try to uninstall X2go and Putty. And then reinstall only X2go and give a try.
We noticed that you tried to connect with your student username as well: this won’t work.

We aren’t aware that you tried the suggestion. You suggested that the issue was maybe your firewall. Did you checked?

In this case you need to install an X server on your Windows, this is out of scope of our support.


I was able to resolve the issue. First, I had to allow X2Go client through my firewall. Then, I had to login to login1.yggdrasil.hpc.unige.ch. The boabab login node is still not working.


good to know it works for you now.

It is working as I was myself connected to it and tried right now. What may happens sometime is that a user session is crashing and you need to stop it and and create a new one.