Cannot find X11 Intrinsic.h


I am trying to build a package on Yggdrasil (the HEASOFT package, HEAsoft - Download (Version 6.28)) and the configure step fails because it cannot locate “Intrinsic.h”:

checking for X... libraries /usr/lib, headers /usr/include
configure: error: Required header X11/Intrinsic.h not found in /usr/include

A quick search tells me this library is part of a package called “libXt-devel” which I guess is not installed. How should I proceed?

Hi there,

Have you tried after having loaded the version provided via module , since it is the same version as the RPM-provided one (cf. hpc:applications_and_libraries [eResearch Doc] )?

[capello@login1 ~]$ yum info libXt-devel.x86_64
Loaded plugins: etckeeper, fastestmirror, langpacks, versionlock
Loading mirror speeds from cached hostfile
Excluding 6 updates due to versionlock (use "yum versionlock status" to show them)
Available Packages
Name        : libXt-devel
Arch        : x86_64
Version     : 1.1.5
Release     : 3.el7
Size        : 446 k
Repo        : Local-CentOS-OS/7/x86_64
Summary     : X.Org X11 libXt development package
URL         :
License     : MIT
Description : X.Org X11 libXt development package

[capello@login1 ~]$ module spider libXt

  libXt: libXt/1.1.5
      libXt provides the X Toolkit Intrinsics, an abstract widget library upon
      which other toolkits are based. Xt is the basis for many toolkits, including
      the Athena widgets (Xaw), and LessTif (a Motif implementation). - Homepage:

    You will need to load all module(s) on any one of the lines below before the "libXt
/1.1.5" module is available to load.

      GCC/4.9.3-2.25  OpenMPI/1.10.2
      icc/2016.1.150-GCC-4.9.3-2.25  impi/
      ifort/2016.1.150-GCC-4.9.3-2.25  impi/
[capello@login1 ~]$ 

Moreover, I know that @Volodymyr.Savchenko was trying to build HEASoft/6.27.2 for module , which would is a better option if other users from the astronomy department need this software.

Or do you specifically need version 6.28?

Thx, bye,

1 Like

Thanks for your answer @Luca.Capello , I wasn’t aware that there is already a module for libXt. Indeed we are several people at the Astronomy Department who would need HEASOFT, if there was a module available it would be best.


Hi @Luca.Capello , libXt/1.1.5 requires me to load GCC/4.9.3, which appears to be too old to allow me to compile HEASOFT. Any way to load this library with a newer version of GCC?

Hi there,

Which GCC version do you prefer (cf. hpc:applications_and_libraries [eResearch Doc] )?

Thx, bye,

If I understand correctly, any relatively new version would do; let’s say 8.3.0

Hi there,

Given that no EasyBuild recipe was available to compile libXt/1.1.15 with newer GCC and porting it is taking too much time, for the moment I have installed libXt-devel as an RPM:

capello@login2:~$ rpm -q libXt-devel

NB , libXt was already there as an RPM because of MATLAB (cf. SOLVED : Graphical interface Matlab not working - #5 by Luca.Capello ).

I will check with @Volodymyr.Savchenko about the HEASoft module .

Thx, bye,

1 Like

Many thanks @Luca.Capello , I was now able to build HEASOFT on Yggdrasil. I built it against the latest versions of compilers I could find, that is, GCCcore/10.2.0 , Python/3.8.6 , and Perl/5.32.0 . Maybe this build can be used to create the module? It lives in /home/users/e/eckertd/heasoft-6.28

1 Like

Hi @Dominique.Eckert, @Luca.Capello !

@Yann.Sagon pointed me to this thread on today’s HPC lunch. Strange I did not get notifications.

Indeed, I built and I noted in there Volodymyr.Savchenko / Easybuild Easyconfigs · GitLab
about this and similar modules.

In particular there are modulefiles there /home/share/astro/test-eb-savchenk/ebmodules

It is possible to easily increase the version of this easyconfig from 6.27.2 to 6.28, there is of course a mechanism to facilitate this with easybuild.

We wanted to publish this easyconfig in official repository, but did not get around to that.
Maybe we can trigger another round of discussion on Astro management level if we need some common effort?

Or since Dominique is perfectly capable of building this software on his own doing something common would be overkill.

By the way, we can not really access @Dominique.Eckert home, that’s restricted and not modifiable.
Common directories, such as those in e /home/share/astro/ should be available to the group.