I was trying to run the Jupyter Notebook

If you are asking for help, try to provide information that can help us solve your issue, such as :

what did you try: I have tried this tutorial, [tutorial] Jupyter notebook. I have copied all the data which is required in a folder on my desktop. I navigate to the folder before I run the command “sbatch launchJupyter.sh”

what didn’t work: It worked smoothly for all the steps but the Jupyter Notebook didn’t open up as instructed in the last step (I have also attached the screenshot of the terminal and firefox.

what was the error message: Firefox can’t establish a connection to the server at localhost:1234.


in the sbatch script, you probably forgot to uncomment line 20 and comment out line 23.

Thank you for the reply and suggestion. Yes, it was the same issue which you mentioned. I checked that as well and the jupyter notebook opened. But When I run the code it again shows me some errors. Which I am sharing here as screenshots. It seems like the numpy.core is not loaded. I followed all the steps which are required to load numpy from Sci package. It will be great if you can help me to resolve this issue.


Hi @Sohaib.Qazi it seems you tried to use Jupyternotebook from Anaconda and loaded Scipy-Bundle for another Python version which isn’t possible. I’m installing JupyterLab which should solve this issue I’ll let you know once done.

Hi, JupyterLab and SciPy installed:

[sagon@login2 ~] $ ml foss/2021b JupyterLab/3.1.6 SciPy-bundle/2021.10

Thank you for the installation :slight_smile:

I will try to run the code and if there are still issues, I will get back to this post. Thank you once again.

I just wanted to check if there is an update about the module installation that we discussed in online lunch session?

Thanks and Best Regards,

Dear @Sohaib.Qazi,

please try like that: [sagon@login2 ~] $ ml foss/2021a JupyterLab/3.0.16 TensorFlow

This is a version without GPus.

Thank you @Yann.Sagon for the installation. I have checked this and the algorithm is working now. But it is without GPUs and the algorithm is taking much time. Is it possible to have Tensor flow with GPU ?


Here it is: New software installed TensorfFlow 2.6 for CUDA

A post was split to a new topic: Request to install Sage