Install.packages failed in Rstudio


I tried to install packages in Rstudio (on Baobab), but Rstudio gives me an error message below.
How could I solve the problem ?
Thank you,




Error: package or namespace load failed for ‘tidync’ in dyn.load(file, DLLpath = DLLpath, …):
unable to load shared object ‘/home/users/b/R/x86_64-pc-linux-gnu-library/4.2/RNetCDF/libs/’: cannot open shared object file: No such file or directory

Dear Mariana,

Did you try to load NetCDF software with command :

ml GCC/12.2.0 OpenMPI/4.1.4 netCDF/4.9.0

Before to install this software?

I seems you miss the library to compile the software.

Best regards,

Thank you for your answer. However, I loaded NetCDF (attached) and it still doesn’t work, same message.


Best regards,

Mariana Bouvier Rabe


I think you have to follow this documentation in order to install R packages :

Best regards,

1 Like

Dear @Mariana.Bouvier-Rabe

The interactive session for R was implemented by @Julien.Prados and he also maintains an R singularity image for his own research group.

He has kindly built a new image by inserting NetCDF. :pray:t3:

You can use the image store here :


I tested it, and it’s working for me.

1 Like