Is sudo available on Baobab?

Dear users,

we receive many emails asking what is the sudo password on Baobab as your password is not working.

The bad news is that sudo isn’t available for users on the cluster.

Every time a user is trying to use sudo, we get a notification. This is the top ten reasons why a user think he need sudo.

User attempt: COMMAND=apt-get install gfortran
User attempt: COMMAND=apt-get install python3-mpi4py
User attempt: COMMAND=add-apt-repository
Admin answer: Our cluster isn’t using a Debian based OS but a Redhat based OS. It means even if you had sudo access the command wouldn’t work, even if you tried multiple time as so user do :wink:. The correct command to use would be yum install gfortran. Anyway, we have dozens of gfortran versions already installed on Baobab, included very recent one, no need to install a new one! We have as well a bunch of Python versions, and we provide as well the package SciPy-bundle/2022.05 which provides numpy, scipy, mpi4py etc.

User attempt: COMMAND=/bin/vim
Admin answer: Even if the file you are trying to open seems to be a bash script, there is no need to open it as user root. On Linux, you are supposed to do everything as possible as normal user and only use privileged account when required. There is no reason why you wouldn’t have access to the file you are trying to open as user if this is your file.

User attempt: COMMAND=/bin/kill -9 70679
Admin answer: this would be a security concern if you would be able to kill a random process on the cluster. If you run a process on a compute node, as soon as you release the resources, all your process are killed automatically. If needed, you can still kill your own process like you are trying to do but without using sudo.

User attempt: COMMAND=/bin/jobs
Admin answer: The user tried to run a program as root without the need to do so. Launching the command as user should work correctly.

User attempt: COMMAND=/sbin/reboot
Admin answer: fortunately, this command doesn’t work as user. Good for us and for other users!

User attempt: COMMAND=/bin/chsh zsh
Admin answer: The user tried to change his default shell. This command should work as user. BUT it doesn’t work as expected on Baobab as we overwrite the change on a regular basis. Please send us a request if you need another default shell and we’ll be happy to help you.

User attempt: COMMAND=apt-get install mysql-server
Admin answer: Baobab isn’t aimed to host a MySQL server. We do provide MySQL client if you need to connect to an outside server. You should check the virtual. If you need a place to host your server, you may check this link

User attempt: COMMAND=/sbin/lshw -C display
Admin answer: Are you interested about the hardware your job run or will run? Are you aware that you can check on this page what hardware is available and you can restrict your job to run on a given CPU or GPU model.

Most of the alerts we receive is about a user trying to install a software we already provide on the cluster centrally. If you are trying to install a software by yourself, please always check what we provide using module, we do provide a lot of software with various versions. If the software you are looking for isn’t there, you can request to install it. If you want to install it yourself, you can check this post for some hints.

1 Like