Issue with X2GO on Yggdrasil

Dear all,

Lately I’ve been having issues using X2GO on Yggdrasil. I am able to start a session correctly and at the beginning things seem to work normally, however as soon as my X2GO session becomes inactive for a few minutes it is no longer accessible, i.e. I can still connect to my X2GO session, but it becomes a frozen window within which nothing is clickable any more. The only solution is to kill the session and start a new one, which I have done several times.

I am running X2GO client on a Mac M1 and my username is eckertd. Until a few weeks ago I did not experience this issue. Below is my setup:

Thanks in advance for your help


Dear Dominique,

I tryed to kill your x2go session, could you please try again to connect and check if all is now ok?

Best regards,

Dear Gael

Thanks for the answer. I tried again but the problem persists


My problem is now solved thanks to disabling the screensaver as done in the other post. Thanks!

Hello Dominique,

Thank to report the status.

Have a nice day,