libGL error: failed to load driver: swrast

Dear HPC team,

Username : henrymi2
Cluster: Yggdrasil

I use a Python package called msnoise ( in a specific conda environment (msnoise_env). On a public-interactive-cpu partition, when trying to plot using the previously mentioned package the following error is displayed :

qt.qpa.xcb: X server does not support XInput 2
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/scratch/runtime-henrymi2'
Qt: Session management error: Could not open network socket
New Data for CH_BALST:CH_BOURR-ZZ-1-1
libGL error: MESA-LOADER: failed to open swrast: /usr/lib64/dri/ cannot open shared object file: No such file or directory (search paths /usr/lib64/dri, suffix _dri)
libGL error: failed to load driver: swrast
qt.qpa.xcb: QXcbConnection: XCB error: 1 (BadRequest), sequence: 168, resource id: 149, major code: 130 (Unknown), minor code: 47

I thought that some modules were lacking so I loaded GCCcore/12.2.0 libGLU/9.0.2 Mesa/22.2.4. It didn’t fix anything. I thought that it could be due to a lack of memory so I ran it on -n1 -c6 --mem-per-cpu=30000 --partition=public-interactive-cpu --time=15:00 --x11, still did not work. I tried running it on a GPU but it didn’t not work either. This error is only present on the cluster.

This error can be reproduced using the command msnoise plot ccftime CH.BALST CH.BOURR in /home/users/h/henrymi2/jupyecke/data/msnoise_v2 after loading “msnoise_env” conda environment.

Thank you in advance for your time.

Best Regards


Could you please provide me the sbatch file used to launch command to analyses issue?

Best regards,