Mounting NASAC on compute nodes

Primary informations

Username: juventin
Cluster: Baobab


To avoid file unnecessary file transfer I would like to mount my NASAC on Baobab. Thanks to the documentation I was able to mount my NASAC on the login node, but I cannot mount it from the compute node.

Steps to Reproduce

To mount the NASAC I used the following command, found in the doc:
dbus-launch bash
gio mount smb:// < /home/users/j/juventin/.credentials
It works on the login node, but not on the compute nodes. For the compute nodes I tried to directly mount the volume in the bash script as recommanded in the documention. My bash script is below


#SBATCH --partition=shared-cpu
#SBATCH --time=00:10:00
#SBATCH --cpus-per-task=1
#SBATCH --ntasks=1
#SBATCH --mem-per-cpu=1000 

dbus-launch bash
gio mount smb:// < /home/users/j/juventin/.credentials


Actual Result

On the compute nodes I get the following error : gio: smb:// volume doesn?t implement mount

Best regards,


can you please do inside your sbatch: which gio and show us the output?

From the bash script, the gio used is /usr/bin/gio . I get the the same output from login node command.

Thanks, I tried myself and wasn’t able to launch dbus-launch bash from a compute node. I guess you had an error in your log file (slurm-%j.out) related to that?.

We’ll check what we can do to solve the issue.

Ok thank you !
In the slurm output I see only an error about “gio volume doesn?t implement mount”, but nothing about the dbus-launch

Hi @Maxime.Juventin this should be fixed:

login2:/home/users/j/juventin$ salloc --nodelist cpu003
salloc: Pending job allocation 5526925
salloc: job 5526925 queued and waiting for resources
salloc: job 5526925 has been allocated resources
salloc: Granted job allocation 5526925
salloc: Waiting for resource configuration
salloc: Nodes cpu003 are ready for job
cpu003:/home/users/j/juventin$ dbus-launch bash
cpu003:/home/users/j/juventin$ gio mount smb:// < .credentials
Password required for share m-gcarleton on
User [juventin]: Domain [SAMBA]: Password:
cpu003:/home/users/j/juventin$ ls /run/user/403714/gvfs/


Hi Yann,
From an “salloc node” it is indeed working now.
However for some reasons, I still cannot mount from my batch file.
The file is the following:

#SBATCH --partition=shared-cpu
#SBATCH --time=00:10:00
#SBATCH --cpus-per-task=1
#SBATCH --ntasks=1
#SBATCH --mem-per-cpu=1000M
dbus-launch bash

gio mount smb:// < /home/users/j/juventin/.credentials

I run sbatch, and the resulting error I get in the slurm%j.out is the following:

Error creating proxy: Could not connect: Connection refused (g-io-error-quark, 39)
gio: smb:// volume doesn?t implement mount

Do you think there is something wrong with my file or the debug-node behaves differently than the other compute nodes ?

Ps: the gio used is still /usr/bin/gio


Hi, do you have the jobid of the job?

I tried as yourself exactly the same sbatch (directory test-sagon in your home directory) and as you can see it was working.

The jobID associated with my previous reply is 5546415
I also went in your test directory, I ran sbatch Something weird happened, two jobs were launched, the 5546916 (succesfull, the NAS was mounted) and the 5546943 (failed, with error : Error creating proxy: Could not connect: Connection refused (g-io-error-quark, 39))
I have let the slurm output in the test-sagon folder.