Request to install nodejs 18

Primary informations

Username: chindemi
Cluster: Yggdrasil



Recent versions of jupyterlab require nodejs >= 18.0.0 to install some common extensions:

ValueError: Please install nodejs >=18.0.0 before continuing. nodejs may be installed using conda or directly from the nodejs website.

Could you please install it?

For reference, I am currently loading these modules:

GCCcore/10.2.0 Tkinter/3.8.6 Python/3.8.6 cuDNN/ git-lfs/3.1.2 FFmpeg/4.3.1 nodejs/12.19.0

Ideally, I would prefer to simply swap nodejs12 for nodejs18, but if the compiler is too old I could update the whole environment… Python 3.8 is losing support anyway.

Thank you very much!

Hi @Giuseppe.Chindemi

Build In progress :wink:

Perfect, thank you Adrien!