VScode on Baobab: The terminal process failed to launch: Path to shell executable "/bin/bash" does not exist


After the update/removal of singularity, I have had issues opening a .sif image through vs-code on baobab.

When I remote connect to the cluster and change to a work folder, I cannot open the terminal in VScode. The error I am getting is: “The terminal process failed to launch: Path to shell executable “/bin/bash” does not exist.”

It is only an issue in VScode. If I ssh into bao and run “apptainer shell -B /srv,/home --nv /home/users/a/algren/singularity_images/ftag-otcalib-pytorch-new-2.sif”, I have no issues using the image.

Host ot~*
  RemoteCommand apptainer shell -B /srv,/home --nv /home/users/a/algren/singularity_images/ftag-otcalib-pytorch-new-2.sif
  RequestTTY yes

Host bao
  HostName baobab2.hpc.unige.ch
  User algren
  RequestTTY yes

Host baogpu ot~baogpu
  HostName gpu023
  User algren
  ProxyJump bao
  RequestTTY yes


Thanks for the help

1 Like


This has been happening for me and a couple others as well.
Seems like anytime I open a new workspace, I get this error. Any clue as to why that might be the case?

Hi All,

I found this:

Could you follow the instruction on this post and let me know if it’s working ?

Hi Adrien,
This seemed to have worked momentarily yesterday, but the error is back again today. Weird.

Did you read and follow the instructions I gave you? Or did it return to normal and then fail again?

For me, this didn’t solve the issue. The issue appears when I change workspaces on a node in singularity/apptainer. I don’t have the issue if I don’t run apptainer shell.

I have found a weird workaround: I use one vs-code window to ssh into a node and open a new one for changing workspaces. Then keeping the old one frozen.

I hope you can find the case of the issue. It start when I changed from using module load ... to apptainer.

So I am having these two errors popping up in my vs code when I have the issue:

I also want to add that myself and a few others are having the same issue starting this week.

We used to be able start a session using vscode by requesting cpu/gpu node.
Modifying our ssh config to match the requested node like so

Host nuflows~*
  RemoteCommand apptainer shell -B /srv,/home --nv /home/users/l/leighm/scratch/Images/nuflows_latest.sif
  RequestTTY yes

Host baobab
  HostName baobab2.hpc.unige.ch
  User leighm

Host baocpu nuflows~baocpu
  HostName cpu277
  User leighm
  ProxyJump baobab

And then launching vscode remote on the node.

However since the start of this week, we have been running into the issue where this method now returns

The terminal process failed to launch: Path to shell executable "/bin/bash" does not exist.

The frustrating part is that sometimes it works, sometimes this error is there. It seems very inconsistent. I have tried killing all of my running nodes, deleting my vscode files on the cluster here:


and deleting all of my local files here


This sometimes helps, but only temporarily. So far I have yet to find a consistent solution.


Dear All,

I apologize for any inconvenience, but vscode and all utilies to implement or using terminal through this kind of sofware are out of our scope and expertise. I recommend reaching out to Microsoft support or visiting the official forum where you can find experts who specialize in vscode and can provide you with the best guidance for your specific needs.

Thank you for understanding,

Hi, one more thing you can try before we give up:

check the remote ssh log as indicated here

We changed something as well: python is now calling python2. Before I was calling /usr/libexec/no-python.

Can you give a try?

One more idea: instead of launching directly apptainer, maybe you can launch a sh script that will launch apptainer. The advantage of proceeding that way is you can log inside the script what is done.