X2go session closing immediately after connection

Hello everyone,

When I try to connect to Baobab frontend using x2go, the graphical window closes immediately after connection. The client displays the status “connecting”, then “running”, then a black graphical window appears and then disappear.

The end of the client log looks like this :

Info: Forwarding X11 connections to display ‘:1’.
Info: Forwarding auxiliary X11 connections to display ‘:1’.
Session: Session started at ‘Sat May 9 21:17:35 Session: Terminating session at ‘Sat May 9 21:18:02 2020’.
Session: Session terminated at ‘Sat May 9 21:18:02 2020’.
Info: Established X server connection.
Info: Using shared memory parameters 0/0K.

So it seems that the connection is established, then terminated. I use the x2go configuration indicated here https://baobab.unige.ch/enduser/src/enduser/access.html . I have the same behavior with Windows or Linux client, and I manage to connect to other x2go servers.

Does anyone have an Idea ?

Best regards
Pierre Kunzli

Hi there,

Indeed, server-side I saw the same symptom you discovered: the connection seems to be established

May  9 21:16:08 login2 sshd[84263]: Accepted publickey for ${USER} from ${IP} port 46510 ssh2: ${ALGORITHM} ${CIPHER}:${FINGERPRINT}
May  9 21:16:08 login2 sshd[84263]: pam_unix(sshd:session): session opened for user ${USER} by (uid=0)
May  9 21:18:10 login2 sshd[84263]: pam_unix(sshd:session): session closed for user ${USER}

If you want to know more, check ~/.x2go/ , each session has its own folder with plenty of logs.

I can not reproduce the error with:

  • (Qt 5.11.3 on Debian buster)
  • (Qt 5.12.5 on Debian bullseye)
  • (Qt 4.8.6 on Windows 10)

Please note that we have not yet updated anything on Baobab (cf. HPC lunch - Next Thursday 14th May ).

Thx, bye,

Hello and thank you for your answer.

For information I simply deleted the content of my ~/.x2go/ folder on Baobab and now it seems to work nicely.

Best regards

1 Like


I have this same issue currently on Yggdrasil. I tried Pierre’s solution of deleting (or in my case, moving) the contents of ~/.x2go/ and still the problem persists. It has been like this for one week now and I would really like to be able to work as normal instead of relying on ssh. Are there any more recent solutions?

Best regards,
~ Erica

Dear Erica,

We has some problems with x2go since we update os to Rocky, but now all seems to be fine. Just try to close (or kill) and open a new one.

Some informations are in this page :slight_smile:
X2Go tends to freeze on Yggdrasil and Baobab since Rocky8 upgrade - HPC Support / HPC issues - HPC Community (unige.ch)

Best regards,

Dear Gael,

Thanks for the information. I can’t close ore kill the session however. This is because it behaves like this:

log in to x2go
Black window with x2go logo opens.
Output reads:
NXPROXY - Version 3.5.0

Copyright (C) 2001, 2010 NoMachine.

See http://www.nomachine.com/ for more information.

Info: Proxy running in client mode with pid ‘30472’.

Session: Starting session at ‘Mon Jun 12 13:07:37 2023’.

Info: Connecting to remote host ‘localhost:53331’.

Info: Connection to remote proxy ‘localhost:53331’ established.

Info: Connection with remote proxy completed.

Warning: Unrecognized session type ‘unix-kde-depth_32’. Assuming agent session.

Warning: Failed to read data from the X auth command.

Warning: Generated a fake cookie for X authentication.

Info: Using ADSL link parameters 512/24/1/0.

Info: Using cache parameters 4/4096KB/8192KB/8192KB.

Info: Using pack method ‘16m-jpeg-9’ with session ‘unix-kde-depth_32’.

Info: Using ZLIB data compression 1/1/32.

Info: Using ZLIB stream compression 4/4.

Info: No suitable cache file found.

Info: Forwarding X11 connections to display ‘localhost:1’.

Session: Session started at ‘Mon Jun 12 13:07:37 2023’.

Info: Established X server connection.

Info: Using shared memory parameters 0/0K.

Session: Terminated at ‘Mon Jun 12 13:06:27 2023’.

The black window then closes by itself maybe 1 second after opening. I have tried to click the ‘power’ button to terminate the session during that 1 second but it doesn’t work. So I can’t kill the session myself.

Best regards,
~ Erica


Thanks for update, do you nee I kill sessions? Are you working on yggdrasil or baobab or both?

Best regards,


If you could kill the Yggdrasil session that would be great. On baobab everything works fine.

Best regards,
~ Erica

Dear Erica,

For sur, I kill all remaining process and x2go configs. Could you please test again to check if the problem is solved?

Best regards,

Hi Gael,

Unfortunately it still behaves the same way, even after I close x2go and open it again.

~ Erica